Answered By: Alison Jones
Last Updated: Dec 02, 2014     Views: 2

The Schubert|it plugin is required to make Ebsco ebooks view properly on a Mac.  You can find out more here: Getting Started and Troubleshooting for Mac Users